digikam as slim version

I had the problem that I don’t run KDE on my desktop, but I want use digikam as my photomanagement software. Since the update to 0.10.0 in the [extra] repository digikam depends on kdegraphics, kdepimlibs and kdebase-runtime. If you don’t run KDE that’s pretty much. So, I have created an alternativate package called digikam-slim. It only depends on the library which are necessary, these are kdelibs, libkdcraw, libkexiv2 and libkipi. Further I have created a second package called kipi-plugins-slim, which also depends only on the libraries above. So you can now use digikam without using all the stuff which comes with kdegraphics, kdebase-runtime and kdepimlibs on your non-KDE desktop.

You can found those packages on the AUR:
libkipi (http://aur.archlinux.org/packages.php?ID=2143)
libkexiv2 (http://aur.archlinux.org/packages.php?ID=24798)
libkdcraw (http://aur.archlinux.org/packages.php?ID=24799)
digikam-slim (http://aur.archlinux.org/packages.php?ID=24993)
kipi-plugins-slim (http://aur.archlinux.org/packages.php?ID=24992)

Maybe you have to change the KDE theme or your Qt theme to fit your needs. I have set my KDE and Qt theme to GTK+.

,

  1. #1 by brolyxxx on 24. August 2010 - 16:30

    Hi, are you going to provide PKGBUILDs for the updated versions of the packages?

    I’d really like to use digikam on my system, but I don’t wanna deal with all that KDE stuff that comes with the conventional version of digikam…

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: